Thursday, 3 March 2011

libdrizzle

We have had several users report issues with libdrizzle lately, but on closer inspection it has been found they are using an old version with known problems.

Back in October we merged libdrizzle into the main drizzle trunk.  All libdrizzle development since then has happened in drizzle rather than the separate libdrizzle project.  We had intended to shut down the libdrizzle project page but for several reasons it had not happened.  The libdrizzle project page now has a message to state that you should use drizzle instead and we have pulled the downloads down.  In the next few weeks we intend to:

  1. kill the libdrizzle project page completely

  2. devise a way to compile just libdrizzle when using the drizzle trunk, omitting the need to have all of drizzle's dependencies to compile it.


On a related note, I have created a release of the drizzle module for PHP on Launchpad which is now compatible with current libdrizzle.  I am also in the process of working on packaging for this as well as a PDO module.

3 comments:

  1. Do you have any impact on libdrizzle1 being required by gearman-job-server on lucid? That package only exists in Natty.

    ReplyDelete
  2. Hi Ian,

    The libdrizzle package in our repositories and in Natty are built from the drizzle release sources so they are good, no change there.

    ReplyDelete